Massive Cyberattack
Incident Report for Helpjuice
Resolved
This incident has been resolved.
Posted Oct 22, 2016 - 00:17 UTC
Monitoring
Requests made to Helpjuice site are not getting through several times because today a massive cyberattack is taking down major websites accross the internet.

More information can be found on: http://www.businessinsider.com/amazon-spotify-twitter-github-and-etsy-down-in-apparent-dns-attack-2016-10
Posted Oct 21, 2016 - 18:05 UTC