System Instability

Incident Report for Helpjuice

Resolved

This incident has been resolved.
Posted 9 years ago. Sep 13, 2016 - 22:56 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted 9 years ago. Sep 13, 2016 - 21:54 UTC

Identified

Our database is under heavy load, which is causing slowness and connections not being responded. We are putting all efforts to get it fixed as soon as possible.
Posted 9 years ago. Sep 13, 2016 - 21:45 UTC